
Drop Menu Magic (DMM) by PVII 

 

DMM is a ground-breaking automatically responsive menu. We like it so much we use it on the PVII site. In a normal 
browser window, the menu items are horizontally arranged and each can include a horizontal sub-menu that drops 
down—with or without one of several very cool animations. When you make your window skinny, or when you 
view your page in a smartphone, the menu magically transforms into a perfectly configured accordion. 

We hope you enjoy using this product as much as we did making it. 

Al Sparber & Gerry Jacobsen PVII 
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5 Install the extension 

Install the extension 

Look for the extension installer file p7_DMM_119.mxp in the root of the zip archive you downloaded. Double-click 
the file to install the extension. Dreamweaver's Extension Manager will open and you will be prompted to complete 
the installation. 

OS X users: If, upon double-clicking the installer, Extension Manager does not properly launch, you have a file 
association issue. To remedy the problem locate the installer file from inside a Finder window and double-click it. 

Work in a defined Dreamweaver site  

Before you begin, make sure you are working inside a defined Dreamweaver web site. This is necessary so that 
Dreamweaver knows how to link required assets. If you are new to Dreamweaver or need to learn how to define a 
web site, follow these simple steps: 

Choose Site > New Site 

Specify local site location  

The Site category of the Site Setup dialog box is the only one you need to fill out to begin working on your 
Dreamweaver site. This category lets you specify the local folder where you’ll store all of your site files. When 
you’re ready, you can fill out the other categories in the Site Setup dialog box, including the Servers category, 
where you can specify a remote folder on your remote server.  

Site Name  

Site Name is the name that appears in the Files panel and in the Manage Sites dialog box; it does not appear in the 
browser.  

Local Site Folder  

Local Site Folder is the folder on your local disk where you store site files, templates, and library items. Create a 
folder on your hard disk or click the folder icon to browse to the folder. When Dreamweaver resolves site root-
relative links, it does so relative to this folder. 
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6 DMM Overview 

DMM Overview 

From the leader in responsive tools for Dreamweaver, comes a ground-breaking responsive drop-down menu 
system. 

One site, one design, all devices 

In a normal browser window, menu items are horizontally arranged and each can include a single horizontal drop-
down sub-menu choreographed to make its entrance with your choice of several optional animations.  

 

When you make your window skinny, or when you view your page in a smartphone, the same menu magically 
transforms into a perfectly configured accordion. A toolbar also appears—giving smartphone users the ability to 
easily hide or show the menu. 

 

Automation 

The Drop Menu Magic system allows you to manage your menu items and options through a dedicated and 
automated interface. It also allows you to add additional menus to your page. 

  



 

 7  

 

7 DMM Overview 

Menu Modes 

Menus can be optioned in 2 modes: 

Default Drop-Down 

In this mode, the root items are horizontally displayed. Sub-menus drop-down and are also displayed horizontally. 

Vertical Accordion 

This mode is perfect for deployment in a sidebar. The menu root links are vertically stacked. Sub-menus are 
revealed by sliding the root links up or down to reveal them. This mode is similar to what all DMM menus look like in 
smartphones—but with slightly different styling and without a hide/show toolbar. 

 

Both menu modes are responsive by default and will display as accordions on smartphones and in narrow windows. 
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8 Inserting a new DMM menu 

Inserting a new DMM menu 

The menu will adapt to the width of the element in which it was inserted—whether that width is fixed or flexible. In 
the absence of a containing element, the menu will stretch the full available width of your browser window. You 
can insert as many individual menus as you like on a page. Each one can be configured independently to set 
different options and features. Multiple DMM menus on a single page can share the same style theme or be set to 
separate themes. 

-Establish the insertion point for your new DMM menu by clicking in the area of the page where you would like it to 
be created.  

-Click the DMM icon  in the PVII Section of Dreamweaver's Insert Bar or choose Insert > Studio VII > Drop Menu 
Magic by PVII. 

Classic Dreamweaver Insert Bar 

 

Dreamweaver Insert Panel 
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9 Inserting a new DMM menu 

The DMM user interface will open in the Create New Drop Menu Magic mode.  

 

Configure your menu, set your options, and then click OK to build the menu at your insertion point. 

You can create as many as you like on your page. 

Tip: When you insert a DMM menu, only the root menu items will be visible in Dreamweaver Design View. The 
menu's functionality can be tested by previewing in a browser. 

Asset folders 

When you create a menu, the system creates an assets folder named p7dmm at the same level as the page that 
contains your menu. This folder will contain a JavaScript file, relevant CSS files, as well as an img sub-folder that 
contains arrow background images used by the CSS.  

 

When you publish your site, make sure you upload the entire p7dmm folder.  
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10 Modifying an existing DMM menu 

Modifying an existing DMM menu  

You can modify any of the existing menus on your page at any time. 

-Click inside the menu that you wish to modify. 

-Click the DMM icon  in the PVII Section of Dreamweaver's Insert Bar or Insert Panel—or choose Modify > 
Studio VII > Modify Drop Menu Magic by PVII 

Note: If you use a Macintosh computer, Apple bugs will sometimes cause the Modify menu to be inactive (grayed 
out). If this happens to you, use the icon to launch the interface. You can also launch the interface from the Insert 
menu. The system will open the interface in the appropriate mode whether you use the Insert Menu, Insert 
Panel/Bar or the Modify menu. 

The Drop Menu Magic User Interface will open in the Modify Existing Drop Menu Magic mode. 

 

Configure your menu items and options and click OK. 
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11 Managing the user interface items 

Managing the user interface items 

Mode 

Displays the current operational Mode for the user interface: either Create or Modify. When in Modify mode, the id 
of the menu being modified will also be displayed. 

Menu Items 

This box displays the text for each navigation link in the menu—one line for each link. Select (click) the line you 
wish to act on. 

Add Item 

Click the Add Item button to add a new menu link. This new item will be created immediately after the selected 
item, and at the same level as the selected item. The newly created menu item will initially appear with the default 
description: “Menu Item” and the URL will simply be a hash (#) placeholder. Change these to suit your needs. The 
Image Path box is always blank by default. 

Add Sub 

DMM supports one sub-menu level per root item. Click the Add Sub button to create a new sub-menu for the 
selected root link item. A new menu item will appear directly beneath the selected menu item, indented one level. 
The newly created menu item will initially appear with the default description: Menu Item and the URL will simply be 
a hash (#). Change these to suit your needs. The Image Path box is always blank by default. 

Delete Item 

Click the Delete button to remove the selected menu item. If the menu item contains a sub-menu level the system 
will completely remove the selected menu item and its sub-menu level. 

Note: The interface requires at least one item to be in the menu list at all times. The system will not allow you to 
delete a menu item if it is the only remaining one. 
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12 Managing the user interface items 

Up  

Click the Up button to move the selected menu item up in the Menu Items list. The menu item, and its sub-menu 
items, will be moved up one position each time the button is clicked. If the menu section before the selected item is 
in the open state (sub-menu items showing) then the selected menu item will be moved to the last position of the 
open menu section. 

Down 

Click the Down button to move the selected menu item down in the Menu List. The menu item, and its sub-menu 
items, will be moved down one position each time the button is clicked. If the menu section after the selected item 
is in the open state (sub-menu items showing) then the selected menu item will be moved to the first position of 
the open menu section. 

Item Link Text 

The Item Link Text box displays the text of the currently selected line in the Menu Items list. The text can be edited 
at any time. The box cannot be left blank. 

Note: If an image has been assigned, this box will be disabled (grayed out) and will instead contain the file name of 
the assigned image. Removing the Image Path will re-enable this box for editing. 

Link Path / Browse...  

Enter the path to the linked page for this menu item or use the Browse button to open the Select File to Link dialog 
box. The system will automatically supply a "#" link placeholder when new menu items are created, which you 
should change to an actual page link before publishing. 
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13 Options 

Image Path / Browse... 

Note: The Image Path box is only used if you are using images for your menu buttons. For text-based menus this 
box should be left empty.  

Enter the path to your image or use the Browse button to open a Select Image Source dialog box. You can change 
the image at any time by selecting the menu item in the Menu Items list and clicking the "Browse..." button. Valid 
image types are limited to the .gif, .jpg, and .png file types. 

The image you select must always be the default state image. The system will automatically handle image pre-
loading. Images for additional states (over, and down), depending on the Image Swap Option you select, must be 
stored in the same folder as your default image. The system will automatically find them. Your Default image file 
name can be anything you like—but you must follow the naming convention for the Over and Down state images. 
If your Normal image is named myButton.gif, the following conventions must be used: 

 The Over image that displays on hover would be named: myButton_over.gif  

 The Down image that displays when its associated sub-menu is open would be named: 

myButton_down.gif 

Image Alt Text 

Enter a description for the related image in the Alt Text box. If the image is a picture of hats, then Hats would be a 
good choice for the text to use. 

Options 

These settings are applied to the current menu. Other menus on the same page can have different options.  
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14 Options 

Menu Mode 

Default Drop Down 

Select this option to display the menu in the default horizontal fashion. The root menu links will display in a 
horizontal bar. Sub-menus will display in a horizontal bar beneath the root menu items. 

Vertical Accordion Style 

Select this option to display the menu vertically in accordion fashion. This Menu Mode is ideal when using the menu 
in a sidebar. 

Vertical Drop Down 

This is a traditional drop-down menu. Use this mode if you have a lot of sub-menu links that would not look good 
wrapping to multiple lines. 

Menu Alignment 

The menu can be aligned in one of three ways, select one of these methods in the drop down listing: 

 Left -All root menu items and sub menu items will be left aligned within the containing 

page element. 

 Centered -All root menu items and sub menu items will be centered within the containing 

page element. 

 Right -All root menu items and sub menu items will be right aligned within the containing 

page element. 

Enable Responsive Conversion 

By default, the menu will adapt to the width of the available browser window or device. The menu will 
automatically convert to a vertical accordion-style menu when the available width is less than a threshold amount 
set in a media query inside the menu CSS file. The default threshold is optimally set to support all smartphones. 

Start with Closed Toolbar State 

By default, when the menu converts into responsive mode for smartphones, it will be closed. The toolbar will 
contain an icon and a text label that will enable users to reveal the menu. 
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15 Options 

Trigger Action 

Enable Mouse Over Action 

Check this box to allow mouse-over activation of the menu triggers. Hovering over a menu trigger will open its sub-
menu. Moving the mouse away from the trigger will close the sub-menu. The click behavior to open or close the 
sub-menu will still remain enabled (supporting keyboard and mobile device users). 

Keep Current Marked Sub Menu Persistent 

Check this box to set the sub menu that is related to the current marked menu item to always be visible 
(persistent)—except when other sub menus are showing. This option is only relevant when the Enable Mouse Over 
Action option is checked. In click-only mode the current sub-menu will display until another menu trigger is clicked. 

Current Marking 

These settings control the operation of the included automatic Current Marking system. 

Enable Current Marking 

Check this box to enable automatic current marking (highlighting) of links in your DMM menu. The system looks for 
links in the menu that match the current page address. When a matching link is found, it's highlighted. The system 
assigns a special style class named current_mark to this link and also to its associated Trigger Link.  

Drop Menu Magic includes an Advanced Current Marker system to allow you to handle exceptions, so that even 
pages that do not appear as links in the menu can have a specified link Current Marked. 

Include URL Parameters in Match 

This option controls whether the automatic current-marking feature will include any URL parameters in the page 
address when looking for a matching link in the menu. Check this box if you wish to have your URL parameters 
included in the match criteria. 
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16 Options 

Image Swap Options 

The system supports up to 3 different image states. Select the Swap Option that you would like to use: 

 Single Image Only -Choose this option if you are using just a single image and do not 

want any swap actions. 

 Normal and Over - Choose this option if you are using two images: one normal image 

and one for the over (hover) state. The over image will also be used as the open (down) 

state and current-mark images. 

 Normal, Over and Open Images - Choose this option if you are using three images: one 

normal image, one for the over (hover) state, and one for the open (down) state. The open 

state image will be used for the current-marker images.  

Note: Be sure to choose the option carefully to match the number of image states you are using. The system will 
pre-load the various state images based on this selection. 

Rollover Open State 

This controls the swap action when the trigger link is in its open state. The system will swap to the over image if the 
trigger link is in the open state and you have a 3-state swap option set. Uncheck the box if you want to disable this 
swap action. 
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17 Options 

Animation Method 

You can choose from 6 animation methods or animation can be turned off. 

Animation List 

 

Duration 

This option allows you to control the animation speed. Duration defines the total amount of time that the 
animation will run, in milliseconds. The default 450 is fine in most cases. Lower the Duration setting and the 
animation will be faster. Raise the setting to make the animation slower. 

Style Theme 

DMM comes with pre-defined CSS style themes that are designed to coordinate with the design of the DMM Page 
Pack that you are using. The listing will show the menu style themes for all of your installed DMM Page Packs. 

 

A preview of the selected Style Theme is displayed to the right of the Style Theme select list. This Preview will 
change whenever you select a different Style Theme. 

Command Buttons 

OK: Click this button to build the menu. You can then preview in a browser to test your menu. 

Cancel: Click this button to completely abort the current operation. This will close the interface and no changes will 
be made to your page. 

Help: Click this button to open the relevant help page in your browser. The help page can remain open while you 
continue working with the Drop Menu Magic interface. 
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18 DMM Remove command 

DMM Remove command 

The Drop Menu Magic system includes a Remove command that allows you to quickly and thoroughly remove an 
existing menu from your page. 

Open the Remove interface  

Open a page that contains one or more DMM menus. Choose Commands > Studio VII > Remove Drop Menu Magic 
to open the Remove interface.  

Note: The Remove option will be unavailable (grayed out) if there are no DMM menus on the page. Some Mac 
systems have compatibility problems with Dreamweaver. If the Remove command is grayed out and inaccessible, 
download and install this command: Return False Fix. After installing it, restart Dreamweaver and your menus will be 
accessible. 

The Remove Drop Menu Magic interface will open. 

 

The interface will provide a listing of all the DMM menus on your page. The list will display the root ID for each 
menu. From the listing, select the menu that you wish to remove. You can remove one menu at a time. 

Tip: If you are unsure about which menu relates to which ID, click the Cancel button and switch to Code View. In 
Code View, locate all IDs that begin with p7DMM. The opening DIV tag for a DMM menu looks like this: <div 
id="p7DMM_1" class="p7DMM01 p7DMM p7dmm-left responsive"> 

What will be removed  

The system will remove the HTML markup for the selected menu. The system will also remove the link to the 
relevant CSS files—if no other menu on the page is using those files. If there are no remaining DMM menus on your 
page, the system will also remove the link to the Drop Menu Magic JavaScript file. 

  

http://www.projectseven.com/go/returnfalsefix
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19 DMM Remove command 

What will not be removed 

The system will not remove the p7dmm assets folder, which may be in use by menus on other pages. This also 
ensures that you will not lose any customized CSS files or images. 

The interface control buttons 

Remove: Click this button to remove the selected menu from the page. 

Cancel: Click this button to completely abort the operation. This will close the interface and no changes will be 
made to your page. 

Help: Click this button to open the associated help file. 
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20 Advanced Current Marker (ACM) 

Advanced Current Marker (ACM) 

This default Current Marker feature works automatically, without user intervention—but it does rely on matching 
the current page's URL to the hyperlinks contained in the menu. In most cases this will work just fine. However, 
when the current page is not reflected as a link in the menu, the current marker will not be able to find a match and 
no links are highlighted. Fortunately, Drop Menu Magic includes an Advanced Current Marker system to allow you 
to handle these exceptions so that even pages that do not appear as links in the menu can have a specified link 
Current Marked. To read more about the ACM system, open the interface on a page that contains a DMM menu and 
click the Help button.  

To open the interface click inside the DMM menu you wish to use the ACM on.  

Then choose Commands > Studio VII > Drop Menu Magic by PVII > Advanced Current Marker Options 

 

Note: The Advanced Current Marker option will be unavailable (grayed out) if there is no Drop Menu Magic html 
markup on the page or if you have not clicked on the menu you wish to act on. 

The Advanced Current Marker user interface will open.  

 

Click the Help button to access the ACM help files. 
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21 Menu styling 

Menu styling 

DMM style themes are associated with the DMM Page Packs you have. Please see the documentation for your Page 
Pack. 

Using DMM on other pages 

DMM is a fully-functioning menu system and can be used on pages other than DMM Page Pack pages. Please see 
the DMM style guide for CSS tips and information on DMM. 

Support and contact info 

PVII quality does not end with your purchase - it continues with the best customer support in the business. 

PVII Knowledge Base  

The PVII Knowledge Base is an online PVII application allowing you to access dozens of Tech Notes, tips, and 
techniques relating to our products, as well as to general web development issues. 

Open the Knowledge Base | View the 10 Most Recent Additions 

PVII Communities 

PVII maintains separate and distinct Web Forum and Newsgroup communities. We do this to ensure you always 
have access via your preferred medium and device. 

1. The PVII Web forums 

The PVII Web Forum is a modern browser-based community, accessible to both desktop and mobile devices and 
requires no additional software or plugins. 

Visit The PVII Web Forum community now... 

  

http://www.projectseven.com/products/templates/pagepacks/dmm/dmm-style-guide/
http://www.projectseven.com/support/questions.asp?
http://www.projectseven.com/products/menusystems/pmm/user_guide/getting_started/before_define.htm
http://www.pviiforums.com/
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22 Support and contact info 

2. PVII Newsgroup forums 

The Project VII Newsgroup is available via private and secure NNTP servers. In order to subscribe to a newsgroup 
you must have a newsgroup-capable client installed such as: 

1. Mozilla Thunderbird 

2. Windows Live Mail 

3. Windows Mail/Outlook Express 

4. Opera Mail 

5. Entourage 

Server: forums.projectseven.com 

Note: PVII newsgroups are private and have nothing to do with usenet feeds that may be provided by your ISP. That 
is, you will not find our newsgroups in a list of newsgroups distributed by your internet service provider. You must set 
up our news server as a new account. 

RSS news feeds 

Keep up with the latest news the minute it's released by subscribing to our RSS news feed. If you are not sure how 
to subscribe, please check this page: 

PVII RSS Info 

Before you contact us 

Before making a support inquiry, please be certain to have read the documentation that came with your product. 
Please include your Dreamweaver version, as well as your computer operating system type in all support 
correspondence. 

E-Mail: 
support@projectseven.com 

Phones: 
330-650-3675 
336-374-4611 

Phone hours are 9:00am - 5:00pm Eastern Time U.S. 

Snail mail 

Project Seven Development 
339 Cristi Lane  
Dobson, NC 27017 

http://www.projectseven.com/xml/index.htm
mailto:support@projectseven.com
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